Borderlands 2 Forum
 

Go Back   Borderlands 2 Forum > Borderlands 2 Discussion Forums > Borderlands 2 General

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 09-18-2012, 09:58 PM
Ragotag Ragotag is offline
Junior Member
 
Join Date: Sep 2012
Posts: 12
Rep Power: 0
Ragotag is on a distinguished road
Default

I think it's a problem on Steam's end. Ever since maintenance this afternoon, Borderlands 2 coop play with friends via Steam has been broken.
Reply With Quote
  #22  
Old 09-18-2012, 10:00 PM
Sacridfire's Avatar
Sacridfire Sacridfire is offline
The Instigator
 
Join Date: Sep 2012
Location: In your basement
Posts: 1,808
Rep Power: 10
Sacridfire is on a distinguished road
Gamer IDs:
Gamertag: Sacridfire694 PSN ID: Sacridfire Steam ID: Sacridfire Raptr ID: Sacridfire
Send a message via Skype™ to Sacridfire
Default

Quote:
Originally Posted by Ragotag View Post
I think it's a problem on Steam's end. Ever since maintenance this afternoon, Borderlands 2 coop play with friends via Steam has been broken.
I have a couple friends in coop games right now (private) so if that is the problem it isn't affecting everybody. Keep an eye on this thread we are working out a solution.
__________________
Thread containing BL2 character builds

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Thanks to MorbidMobius for the sig.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Reply With Quote
  #23  
Old 09-18-2012, 10:31 PM
monkeyclaw monkeyclaw is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Rep Power: 0
monkeyclaw is on a distinguished road
Default

So, it seems like in a group of my friends, 2 of us could connect to each other but a third could not join anyone.

So, the two of us that COULD connect, we closed our steam and launched it a gain. This might have updated our steam build to the current, and then all 3 of us could play together.

So have ALL of your friends you are trying to connect with close steam, wait, and launch steam again and try to connect to each other.
Reply With Quote
  #24  
Old 09-18-2012, 11:24 PM
Phrostt Phrostt is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Rep Power: 0
Phrostt is on a distinguished road
Default How to fix

This assumes you are using a PC on a home network like most normal people.

You need to activate a DMZ (de-militarized zone) on your router that allows strangers from the internet access to random ports on your PC.

[All these steps should be undone when not playing since it leaves you open for attack]

In my case I have [PC]-->linksys wireless router<---->verizon fios router<--->INTERNET

So first on your PC go to control panel, security, windows firewall, and turn off windows firewall.

Then go to run, type 'cmd' to get the dos prompt up.
Run the command

C:\>ipconfig /all

Find the line labeled "IPv4 Address" and write that. Usually it's something like "192.168.1.5"




Now login to your LinkSys or whatever router by putting 192.168.1.1 into your address bar. (It may be a different address, if that doesn't work, try 192.168.1.2, 192.168.1.3, etc.



The name/pw is usually "admin" and "admin" for both. But if you changed them they're different.

Now search around for a setting called 'DMZ' ... linksys puts it under gaming.

Enable a DMZ for the IP address you looked up using ipconfig... that 192.168.1.5 for example.

Save.


That's it.

In my case I had to do both my Fios router and the wireless linksys router I connected to it. Most people will just have one router. Good luck.
Reply With Quote
  #25  
Old 09-18-2012, 11:46 PM
Sigrosa Sigrosa is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Rep Power: 0
Sigrosa is on a distinguished road
Default

Quote:
Originally Posted by Sacridfire View Post
Alright try this.

Within Steam

1. Click "Property" from pop up menu for "Dungeon defenders" go to Borderlands 2 instead obviously.
2. In "General" tab, Click "Set Launch options"
3. Add "-tcp"
I'm not sure what this was supposed to do, but I tried it.

Didn't work.

I also really hate port forwarding and would rather play single player than go through that junk just to play one session with some friends. I hope they fix it soon...
Also all of my friends restarted steam and it still wasn't working.

Last edited by Sigrosa; 09-18-2012 at 11:49 PM.
Reply With Quote
  #26  
Old 09-19-2012, 12:00 AM
HylianZ HylianZ is offline
Junior Member
 
Join Date: Sep 2012
Posts: 3
Rep Power: 0
HylianZ is on a distinguished road
Default

I was having the same problems, so i decided to try a few things out. Nothing worked that was suggested, so i did my own thing. I went into my windows firewall and went to the inbound connections and saw there were multiple rules for borderlands 2 and steam. I deleted them all and re launched the game. The firewall asked me fir permission again and i says to allow it and then it worked perfectly. No guarantee it will work for you, but give it a shoot.

Recap:
Go to inbound connections in your firewall settings and delete the rules for borderlands 2. Then re-launch the game and allow it when the firewall pops up.
Reply With Quote
  #27  
Old 09-19-2012, 12:18 AM
bob bob is offline
Junior Member
 
Join Date: Sep 2012
Posts: 2
Rep Power: 0
bob is on a distinguished road
Default

i may have found a solution, until they fix it, this is a temporary fix. my friends had the same issue, so we set up a hamachi server. it works perfect. try it out, just set up a server, friends join and invite like normal. we had 3 people. hope this helps
Reply With Quote
  #28  
Old 09-19-2012, 12:25 AM
Sigrosa Sigrosa is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Rep Power: 0
Sigrosa is on a distinguished road
Default

Quote:
Originally Posted by HylianZ View Post
I was having the same problems, so i decided to try a few things out. Nothing worked that was suggested, so i did my own thing. I went into my windows firewall and went to the inbound connections and saw there were multiple rules for borderlands 2 and steam. I deleted them all and re launched the game. The firewall asked me fir permission again and i says to allow it and then it worked perfectly. No guarantee it will work for you, but give it a shoot.

Recap:
Go to inbound connections in your firewall settings and delete the rules for borderlands 2. Then re-launch the game and allow it when the firewall pops up.
There were multiple rules for borderlands 2 in my firewall settings also, however it didn't work for me.

Edit: I can join games using the quick match system now, however I cannot join my friend's games still. So this MAY work for some people and their friends... I would say try this first as it has given me partial results.
Edit 2: Had a friend try using this process as well and then trying to connect using the friends network, followed by LAN. He had 6 copies of borderlands permissions in his firewall settings but were still unable to connect to each other. I don't understand what's going on at all anymore, hope all these posts help somebody...
Edit 3: Spent some time on the online game list refreshing it to see my results. I got between 5-8 games from ~10 refreshes (All the same players) at 1 AM 9/19/12 central time. It seems like more should be showing up unless everyone is using private settings but it IS early... anyway... my friend had public matching enabled while I did these searches and his game did NOT appear. Also somebody else joined his match while I was searching for it. I'm running out of ideas...
Edit 4: Had my friend use the match finder at the same time as I did. I got the same results in edit# 3, however he got 15 games all within the level 20 range. He couldn't join me once I was any games I found on my matchmaking list. I had one last idea to have him host a game within my character's level range and see if I could find him on the public list.

So I start a level 1 character and open matchmaking. Games levels 1-4 appear (15 of them) however his doesn't appear after multiple tries. Seems like matchmaking only shows games near your own level, but I still can't see his game for some reason on the games list. (he did have public hosting enabled)

This is why this issue is so confusing. I can see some people's games consistently using the public games list and I have been able to join all of them. I cannot join my friend's game from the friend's list and his game will not show up on the public list. However, other players can join his game??

Conclusion: Shit's broken.

Last edited by Sigrosa; 09-19-2012 at 01:33 AM.
Reply With Quote
  #29  
Old 09-19-2012, 01:17 AM
buggz buggz is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Rep Power: 0
buggz is on a distinguished road
Unhappy Can't play with friends and pissed!

I'm absolutely PISSED that I can't play with my friends. This is the main reason I wanted to play the game —and the main reason we bought the four-pack. We were all waiting eagerly at our computers for this to come out and it just doesn't work. The graphics are beautiful. The game play is amazing —but if you can't play with friends— what's the point!?

I'm sorry to sound angry. I would just like to hear from the developers that they are investigating this problem and that they are working on a solution.

I've tried all the solutions in this thread, but nothing works. Please Gearbox, let us know that you are aware of this issue and are working on it.

Operating System: Windows 7 Home Premium, 64-bit (Service Pack 1)
DirectX version: 11.0
GPU processor: GeForce GTX 460
Driver version: 306.23
DirectX support: 11.1

Antivirus: Microsoft Security Essentials
ISP: CenturyLink

Last edited by buggz; 09-19-2012 at 03:10 AM.
Reply With Quote
  #30  
Old 09-19-2012, 01:37 AM
Extra Krispy Extra Krispy is offline
Junior Member
 
Join Date: Sep 2012
Posts: 4
Rep Power: 0
Extra Krispy is on a distinguished road
Default

As a host to enable friends to join one fix is to enable DMZ host in the firewall section of your router control panel this applying to Dlink routers
(gaming option for Linksys). Keep in mind this opens your pc ports a little more than normal and may pose some security risks but you just want to play right? Also on same page I removed NAT end point filter restrictions on both UDP and TCP ports. From another forum one user posted the port forwarding ports to open TCP ports 7777, 28900, 27900, 28910; UDP ports 7777, 6500, 9989 I never needed to go that far but this may be another fix until its patched.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:20 PM.


This site is not affiliated with or endorsed by Gearbox Software, LLC, their partners or sponsors.
We act solely as a fansite and all information contained herein is for entertainment purposes only.
All trademarks and copyrights remain the property of their respective owners.

Black Ops 2 - Halo 4 - Borderlands 2

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Ad Management plugin by RedTyger